Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #36896


    I’m struggling to find a solution to a problem. I’ve been using Cookie Notice for some time now without any hitches ?. However today I came to change some setting only to be presented with a 404 page when clicking ‘Save Changes’.

    My console tells me that ‘wp-admin/options.php’ does not exist. But it does exist and I can get to it manually.

    There are no error_logs created for this problem.

    I’m on the latest install of WordPress and the latest version of Cookie Notice.

    I have disabled all other plugins and changed my theme to 2020.

    I have tried PHP 7,1, 7.2 and 7.3.

    I’ve upped max_execution_time, max_input_time, max_input_vars and memory_limit.

    I have deleted my .htaccess and started with a fresh one.

    I have visited and clicked save on the Permalinks settings page.

    But none of these make a difference, I’m still presented with a 404 and the new Cookie notice settings are not saved.

    The only way I’ve found to make this work is to disable modSecurity in my hosting account—which surely is not a viable solution… is it?

    Do you have any suggestions of where I can go from here to resolve this without turning off modSecurity?



    UPDATE: I’ve now solved this.

    It was indeed down to ModSecurity, or a particular rule therein. My Server Admin was able to see which rule was being triggered and remove it so the plugin can now save changes to setting. The rule was related to “Potential Cross Site Scripting Attack”.


    The plugin is using WP native settings API so probably you would experience saving issues with other WP plugins.
    Glad you found a solution.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.