Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #1272
    Damian Mekal
    Participant

    After last wordpress update your plugin is now working, I think. I have checked it installed on my two sites and for both have the same problem. Please see http://www.kapuczina.eu

    #1277
    Bartosz
    Keymaster

    Damian, there’s a JS error in your theme:

    Error: TypeError: $.backstretch is not a function
    Source: http://kapuczina.eu/wp-content/themes/publisher/js/custom.js?ver=20130731
    Line: 107

    #1280
    Damian Mekal
    Participant

    Thank you Bartosz. Problem is already fixed.

    #1281
    wilburlikesmith
    Participant

    Hi,

    Same problem, sorry I didn’t come here first. I left a comment. Could it be Tesla Theme problem or perhaps because it’s still a localhost copy? If it’s not the latter I will publish it and supply you with the link.

    #1282
    Bartosz
    Keymaster

    No problem Wilbur.
    We need a link to find out what’s the issue in your case.

    #1284
    wilburlikesmith
    Participant

    Will this work? Bongalong

    #1285
    Bartosz
    Keymaster

    We’ve seen such a crazy solutions with premium themes that it’s hard to say. But if your theme is developed with WordPress standards – of course. Just install at take a look.

    #1286
    wilburlikesmith
    Participant

    I know they have portfolio and slider options, but I didn’t want to get into it too much right now, was just hoping for a smooth quick lightbox solution…

    #1320
    wilburlikesmith
    Participant

    Hi Bartosz, me again. I’ve tried again bongalong.co.za/the-bong. Would be nice if you can have a look :)

    #1321
    Bartosz
    Keymaster

    You have Swipebox script added twice – by our plugin and by your theme, what generates an obvious conflict. Try removing the code embedding Swipebox from your theme and see if it works.

    #1324
    wilburlikesmith
    Participant

    Thanks I’ll have a look at it now! (why didn’t I think of that)

    Update:
    mmm, I’ve commented out this line (and deleted it when the commenting didn’t work) from my theme’s functions.php, which didn’t work.
    wp_enqueue_script('swipebox', THEMEROOT . '//cdn.dfactory.co/js/jquery.swipebox.min.js', array('jquery'), false, true);
    Then on my local copy I tried removing this piece of code from the plugin and it also didn’t work…
    wp_register_script(
    'responsive-lightbox-swipebox',
    plugins_url('assets/swipebox/source/jquery.swipebox.min.js', __FILE__),
    array('jquery')
    );

    Take note that I don’t always really know what I’m doing :)

    #1326
    wilburlikesmith
    Participant
    This reply has been marked as private.
    #1327
    Bartosz
    Keymaster

    It’s good you removed the code from theme, but if you also removed the code from plugin you’ll end up with no script at all.

    (but I don’t see it being removed on your site)

    #1328
    wilburlikesmith
    Participant

    I only removed one at a time putting the other back, maybe not that much of a noob :p

    I’ve put it back when it didn’t work. Removed the code from the theme again, there should only be one now (after this comment). bongalong.co.za/the-bong

    #1329
    Bartosz
    Keymaster

    There is a problem still. But I noticed that your theme was modifying the Swipebox script (a JS code somhere) and the lightbox appearance, now it causes the issues like not displaying the lightbox. It’s hard to say where it is and what it really does.

    Please try to find and remove that code, but first switch to a different script (in RW settings) and see if it affects SwipeBox only or other lightbox scripts too.

    #1802
    wilburlikesmith
    Participant

    Hi Bartosz, long time :) Hope you had a great festive season and all the best for 2014!

    Still struggling to get it to work… Theme is Cool Stuff http://teslathemes.com/wp-themes/coolstuff/

    I’ve tried removing the swipebox.min from the plugin with no luck. I also tried Nivo, Fancy and pretty to no avail :( SwipeBox is currently activated with these comments:

    		elseif($this->options['settings']['script'] === 'swipebox')
    		{
    			// commented out because the theme has it already
    
    			//wp_register_script(
    			//	'responsive-lightbox-swipebox',
    			//	plugins_url('assets/swipebox/source/jquery.swipebox.min.js', __FILE__),
    			//	array('jquery')
    			//);

    Here’s the page http://bongalong.co.za/shop/ and my gallery code (nothing really).
    [gallery columns="6" ids="47,53,49,50,29,46" orderby="rand"]

    Thanks again! ps. it’s working great on another site I’m busy with!

    #1806
    Bartosz
    Keymaster

    Hi and thank you :)

    The problem remains because the script is still active – I ment not remove the swipebox script from the plugin but from your theme.

    Please try that.

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.