Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #844
    Mark Shaw
    Participant

    I can easily press the “Escape” key to exit the lightbox window on an enlarged image, but I see absolutely no “Close” or “X” button? Am I going crazy or is this supposed to exist somewhere?

    #845
    Bartosz
    Keymaster

    Hi Mark,

    Can you post a link to your site?

    #846
    Mark Shaw
    Participant
    This reply has been marked as private.
    #847
    Bartosz
    Keymaster

    No problem.

    The path to lighbtox navigation images is correct, but images don’t exist – thus it’s not visible. However it is possible to get to this url, so the access is not permitted (which is good).

    Try the following:
    1. Deactivate the plugin and delete it.
    2. Install the plugin again.
    3. Check if it’s working
    4. If not, please check if those icons exist in plugins folder

    #848
    Mark Shaw
    Participant

    Hey again Bartosz, I went ahead and deactivated/deleted/reinstalled and unfortunately still no close buttons.

    I checked the wp-content/plugins/responsive-lightbox/images folder and only saw the “logo-dfactory.png” image. Nothing else.

    By any chance could tell me where to obtain the images necessary for those close buttons and I could try to manually upload them?

    Thanks for all your help!

    #849
    Mark Shaw
    Participant

    Sorry, I take that back… I noticed the image location is an SVG file located in: wp-content/plugins/responsive-lightbox/assets/swipebox/source/img/icons.svg

    That file does indeed exist but it’s not showing up in Google Chrome or IE10.

    #850
    Bartosz
    Keymaster

    Not in this folder. Look for it in wp-content/plugins/responsive-lightbox/assets/swipebox/source/img

    #851
    Bartosz
    Keymaster

    Ok, just add this to your CSS stylesheet (and remember to modify the path if your site url changes)

    #swipebox-action #swipebox-close, #swipebox-action #swipebox-prev, #swipebox-action #swipebox-next { background-image: url(“http://crabsoc.com/test/wp-content/plugins/responsive-lightbox/assets/swipebox/source/img/icons.png”) !important; }

    We’re just switching from svg icons to png icons here. (but maybe we’ll think of adding an option to the plugin for such cases – it’s rare but it happens on some servers)

    #852
    Mark Shaw
    Participant

    Thank you so much Bartosz. That worked like a champ my friend. It appears the absolute path is necessary when WP is installed in a sub-directory. I might be able to remove this code once the site is launched in its proper root location. I really appreciate your quick help with this. This support is unsurpassed! Hope you have an excellent day!

    #1072
    Brett Weaver
    Participant

    Hi,

    I have the same issue with the close, next and previous images not being visible. An example page is here:

    http://mainstreetlawrenceburgtn.com/heritage-festival-2013-gallery/

    I really like the swipebox version of the plugin and would like to get this working. I’ve tried deleting and re-installing the plugin as well as adding the absolute path to the images in swipebox.css. Nothing seems to work. I can see the .png at the url separately in the browser.

    A note is that I have it working on a subdomain/dev location, but I migrated to the permanent hosting to a sub-directory of the root. It’s not “my” hosting account. We’re working with someone else in this instance. The admin moved the site files, etc. without consulting me and I had to make some changes to .htaccess. All seems to be working but these navigation images. Not sure if this is relevant, but thought I would mention it. Any assistance would be appreciated.

    Thanks.

    #1073
    Bartosz
    Keymaster

    Brett, we are aware of the issue and it will be fixed shortly. Just a quick fix for you

    #swipebox-action #swipebox-close, #swipebox-action #swipebox-prev, #swipebox-action #swipebox-next { background-image: url(“http://mainstreetlawrenceburgtn.com/wp-content/plugins/responsive-lightbox/assets/swipebox/source/img/icons.png”) !important; }

    #1074
    Brett Weaver
    Participant

    Thanks Bartosz. I could have sworn I tried that per the previous post, but I must have had something wrong. This code worked. Thanks a bunch!
    Brett

    #1480
    Beat Richli
    Participant

    Bartosz, your snipped saved me too. i was about to place custom png’s when noticing that they work, but your snipped saved me quite some time.

    just wanted to add: “swipeBox” worked like a charm on another website with same base theme, just a day before. i more or less copy pasted the code to generate the image list. same plugin version etc. controls don’t show up. they are there, but not visible. i fiddled arround with z-index and suddenly they all showed (even though, IMO they shouldn’t have…). i applied the css, but didn’t work and couldn’t get it to work again.
    anyway, great plugin.

    #1492
    Bartosz
    Keymaster

    Bea,e probably you did not adjust the icon image path – it should be different on every install. (but did you try the option to force png icons in current version of the plugin?)

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.