Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • #3598

    Hi there,

    plugin doesn’t work when I recently update to newest version.

    Is there any way to repair it? It’s kind of important for me, because we are bulding a new website for our corporation and this is a really handfull plugin.

    best regards,


    Xialo, can you post a link to your site. Or admin access too – using Set as private reply.


    When I said – “update to newest version.” I mean new WordPress version / my bad expression

    Anyway, I would like to give you a control over it, but the site running on localhost.

    I was concider downgrade WordPress back to 3.8.3 but I’m not sure what happen to DB because new version made few changes in core files, I guess.

    ad. I got lessons – never ever upgrade immediately to newest version, just wait til leverything will settle down. =D



    It works with WP 3.9 on our installs, but it definitely requires more tests – DA uses WP editor API, especially JS events. 3.9 have changed a couple of things there.


    I’m soooo sorry. I didn’t even disable all plugins… – oh, man, what a hysterical woman I am.

    So, it is not problem with your plugin, but with other plugin – don’t know which one yet.

    basically, it does not allow to add any files to page, post, … – when you click on “add new attachment” button become inactive.

    Anyway, it work and that is important.

    So, again, sorry for this “hysteria” and seriously – this is must-have plugin for me.

    and sorry for my english, (:

    best regards,



    :) no problem. happy to hear it working for you

    Andrew Lawless

    Ever since upgrade to WP 3.9 I am getting the following error message when trying to attach a file:

    Unexpected error occured. Please refresh the page and try again.

    I can attach a file in ‘Attachments’ itself and then display the link in the same post. But when I try to attach the same file from within the post, I am getting this error. Everything worked fine before upgrade to WP 3.9

    George Laing


    I am trying to install this plugin to a 3.9.2 WordPress Site.

    It installs ok, and activates.

    I was then able to set the plugin to operate on my ‘pages’.

    This appears to work correctly and is visible on the ‘page’ editor window.

    I then try to ‘Add a new attachment’, I get the selection window, but after clicking ‘Add selected Attachments’ I get the following:

    Unexpected error occured. Please refresh the page and try again.

    I have tried disabling all of my other plugins, but this seems to make no difference.

    Please could someone advise me on my next steps.

    Many Thanks,


    Did you try that on a different theme or blank WP install?

    Andrew Lawless

    I am having the same issue. Ever since my update to WP 3.9 I am getting the same error message. The shortcode works, but not when I try embedding it via the download attachment box in the admin window. I am also quite surprised to read that this problem has been around for a while for many users, and all we are getting is passive aggressiveness, i.e. ‘Did you try that on a different theme or blank WP install?’

    The plugin worked before upgrade to 3.9, now it does not with the same plugins and themes installed. I have not even received a reply to my support query on 21 May 2014 at 22:33.

    Am I correct in my assumption that you are not interested in solving the issue?

    Just need to know, as I do not want to waste my time waiting….



    First, the question: ‘Did you try that on a different theme or blank WP install?’ is definitely not a passive aggressiveness. People are using multiple themes, plugins, servers etc. You’ll be surprised how often that question leads our users to the conclusion that the theme or plugin they are using is poorly coded and conflicts or breaks other scripts or plugins. So we ask them to check what the situation is before we proceed with something. That’s the context.

    Now in your case, you updated to WordPress 3.9.
    Did you update the plugin too?
    Did you update any other plugins?
    Did you update the theme?
    Were all updates successful?
    Did you try to resave plugin settings?
    Did you try to reset plugin to defaults?
    Did you try to deactivate, remove and install the plugin and activate again?
    Finally… Did you try the plugin on a different theme or blank WP install?

    Those are all important questions.

    Generally, everyone makes mistakes, so I’m not saying there is no bug here. But there are probably hundreds of users of Download Attachments. And for now we have 2 users stating that there’s an issue. If there was something seriously broken we’d definitely know that, believe me.

    We’d like to solve that but we need more info and cooperation from your side.

    Unfortunatelly, when it come’s to waiting… we’re on vacation till the end of August. I may be active on the support forum ,but any development work on this free plugin is not possible earlier.

    George Laing

    Hi Bartosz,

    Sorry for delay in getting back to you – I’ve been away.

    I have now tested the plugin using the Twenty Fourteen theme and it works fine. I can add a document and view it on the page. I can also view the file if I then swap back to my custom theme, but I am then unable to add any new files as before. So as you say – it must be to do with my theme.

    Please could you offer some advice on where to start looking to debug this with my theme?

    Many Thanks,


    It might be a Javascript error in the post edit screen I guess.

    Try to debug this using any of the developer tools available for your browser – it’s the best way to find out.

    George Laing

    This is what FireBug tells me…

    POST /wp-admin/admin-ajax.php 200 OK 735ms

    Pragma no-cache
    Date Thu, 04 Sep 2014 13:39:30 GMT
    X-Content-Type-Options nosniff
    Server Apache
    X-Frame-Options SAMEORIGIN
    Transfer-Encoding Identity
    Content-Type text/html; charset=UTF-8
    Cache-Control no-cache, must-revalidate, max-age=0
    Access-Control-Allow-Credentials true
    Connection Keep-Alive
    X-Robots-Tag noindex
    Keep-Alive timeout=5, max=96
    Expires Wed, 11 Jan 1984 05:00:00 GMT

    Content-Type application/x-www-form-urlencoded; charset=UTF-8
    Accept */*
    X-Requested-With XMLHttpRequest

    Parameters application/x-www-form-urlencoded
    action da-new-file
    attachments_ids[] 1221
    danonce b6741c3cb8
    post_id 0

    {“status”:”ERROR”,”files”:[],”info”:”Unexpected error occured. Please refresh the page and try again.”}

    files []
    info “Unexpected error occured. Please refresh the page and try again.”
    status “ERROR”

    Does this help?


    A bit :)

    We know that Ajax is running so you have no JS error. But still, I believe it’s a JS issue – maybe a JS conflict with a script enqueued by the them.

    Is there a way you contact the theme developer to help you out with this?

    George Laing
    This reply has been marked as private.
    George Laing

    I have fixed it – I was missing some functions in the Theme Functions page.

    I used an updated blank theme’s page and updated my theme.

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.